Loading...

Error with OMA-URI in Intune: Always be careful after Copy Paste


In this post I will show you a quick feedback about a stupid and annoying issue that everyone may occur with deploying OMA-URI.

Context
We wanted to manage Google Chrome with Intune.
For that you have to first create an OMA-URI to "ingest" Chrome ADMX.
Then we plan to set some policies like Home page, bookmarks...
The issue that the home page was not applied.

Our first step
To manage Chrome settings you have to use OMA-URI in Intune.
As mentioned previously the first step is to add Chrome ADMX.
For that proceed we will proceed as below.

Download Chrome ADMX 
1. Go to this link.
2. Go to the part Chrome ADM/ADMX Templates
3. Click on Download
4. Go to policy_templates\windows\admx
5. The file we will need is Chrome.admx

Import ADMX in Intune
1. Go to Intune > Device Configuration
2. Go to Profiles
3. Click on Create profile
4. In Platform, select Windows 10 and later
5. In Profile, select Custom
6. Click on Create
7. In the Name field type Import ADMX
8. In the OMA-URI settings, click on Add
9. In the Name field type Import ADMX
10. In OMA-URI field type the below one:
11. In Data type, select XML
12. In the value field type the content of the Chrome.admx


The issue
The next step was to configure the Chrome page.
Chrome has many policies available to configure its browser.
See here the list of all policies. 
To configure home page, we will use HomepageLocation.
The OMA-URI part to use is the following:
Our issue was the policy has been created by following all rules.
However the home page was not applied.

Check Intune status
In the Intune portal the CSP profile returns -2016281112 (Remediation failed) that can be translated to error code 0x87d1fde8.

Not very well explained.

Check on the the computer
Go to event log
Go to DeviceManagement-Enterprise-Diagnostics-Provider
You can find the below event:

What the hell is going on.

A stupid issue
The issue was really stupid.
When you copy something from website or in the portal some characters may be wrong.
To configure the home page you have to use the value below:
In our case after copying this one the following charater " has been replaced with ”.
See the overview:
This fuc.i.. character was the issue, what the helllllllll.

Now after changing this one the OMA-URI has been correctly applied.
On the computer type: chrome://policy then you should see the policies.

OMA-URI 1421369837657915967

Publier un commentaire

2 commentaires

Mathieu Aït Azzouzène a dit…
Ce commentaire a été supprimé par son auteur.
Mathieu Aït Azzouzène a dit…

It happens all the time! The first time I encountered this issue I spent hours to figure out was going on

Accueil item

Award

Mes articles en français

Author of Books

PowerShell GUI & WPF Group

PowerShell GUI & WPF Group

Join the FPSUGR

Join the FPSUGR

Stats